[solved] Problem creating boot delegation class loader


when running the dmx-linux.sh, I get the error message below.
What can can I do to solve it and make dmx run?

Thank You? :slight_smile:

Problem creating boot delegation class loader: java.lang.reflect.InaccessibleObjectException: Unable to make protected java.security.SecureClassLoader(java.lang.ClassLoader) accessible: module java.base does not “opens java.security” to unnamed module @6fd02e5

Welcome to Apache Felix Gogo


Hello @OhmRa and welcome to our forum!

Most likely the error message comes from a wrong Java version. DMX requires Java 8. Did you install that on your machine and is it the only Java version installed? What Linux distribution do you use?

Thank you very much for getting in touch!


Hello Jürgen,

thanks for the welcome and for your help.

Wonderful! There had been two Java versions installed. I removed everything but

  • jre8-openjdk
  • jre8-openjdk-headless
  • java-runtime-common

Now it works! Thank you!

The machine runs with Obarun.

Best Wishes,